EEM External User Store Connection Showing "Bind Failed"

book

Article ID: 6776

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent

Issue/Introduction

In the EEM External User Store configuration, the configured connection to the LDAP server is showing "Bind Failed" for the connection status. No users from LDAP can be seen in the "Manage Identities" tab within the EEM GUI.

Cause

When an EEM/LDAP connection is showing "Bind Failed", this typically means one of two things...

1. The target LDAP server is unreachable.

2. There is a problem with the UserDN specified in the connection.

Environment

Release: ATSYHA99000-11.3.6-Workload Automation AE-High Availability Option
Component:

Resolution

Check the network connectivity between the EEM Server and the configured LDAP server. Also make sure the specified port is correct and open through the firewall. Your LDAP admin should be able to verify the correct port that would be used in your environment.

If the connectivity is good, make sure the password specified for the UserDN is correct. A common root cause for this issue is a password change for this user. If the password changes for the UserDN, it must be updated manually in the EEM/LDAP configuration. A less common root cause related to the user would be that the user does not have permission to query ldap. This would need to be checked by your LDAP admin.