Portal: Failed to open the file disk1.cab

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Article ID: 6770

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

While installing the TDM Portal, I am receiving the following error message: 

MSI (s) (50:38) [17:33:26:173]: SECREPAIR: Failed to open the file:C:\Users\demo\AppData\Roaming\CA\CA Test Data Manager Portal 4.X.X.XX\install\disk1.cab for computing its hash. Error:2 

Cause

The main problem is that there are remnants of the older code (services, files, folders, etc.) after installing the newer version. After a reboot and deleting those components, the install should work smoothly. You can also see this error if you are using Windows 2008 SP2 instead of Windows 2008 R2, the supported version. 

Environment

CA Test Data Manager (TDM)- Portal

Resolution

Delete the older services manually and delete the CA TDM Portal folder. 

1. To delete remnant services, in the Windows Command prompt type: SC DELETE <service_name> 
2. Delete the folder C:\Program Files\CA\CA Test Data Manager Portal. 
3. Reboot your machine. 
4. Continue or restart the installation.

Additional Information

If you experience any further issues, please open a support case by going to https://www.ca.com/us/services-support/ca-support/contact-support.html.