"Duplicate entry detected" and "Failed to create key" ERRORS (i.e. ObjectCalss=xpsKey)
search cancel

"Duplicate entry detected" and "Failed to create key" ERRORS (i.e. ObjectCalss=xpsKey)

book

Article ID: 6695

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

When XPSSweeper command was performed, below error occurred. 

 

 (ERROR) : [sm-xpsxps-00670] Duplicate entry detected. 

 (ERROR) : [sm-xpsxps-04530] Failed to create key for CA.SM::[email protected](noprotect_fortest) 

Environment

Release: ESPSTM99000-12.51-Single Sign On-Extended Support Plus
Component:

Cause

It is caused by duplicate ObjectClass xpsKey. 

xpsKey entry is intended to prevent duplicate names. However, in reality, this is of no practical value, because before storing an object into the Policy Store, one of validation tasks checks uniqueness of name.

 

Resolution

The objectclass xpsKey has been phased out and removed completerly in 12.6 version as this ObjectClass is not needed. 

 

Additional Information

If you encountered the error in older release, you will need to manually remove all the indexes (i.e. ObjectCalss=xpsKey) from the policy store.

Please refer to below document.

 

 TEC1881072