How to prevent the error "Agent is Busy taking Thread dump" when collecting new thread dump via Introscope Workstation?

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Article ID: 6646

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Updated On:

Products

APP PERF MANAGEMENT CA Application Performance Management Agent (APM / Wily / Introscope) CUSTOMER EXPERIENCE MANAGER INTROSCOPE

Issue/Introduction

When using the "Collect New" option in the Thread Dumps tab in Workstation Investigator to collect thread dumps for an agent, the following error was prompted:

 

Agent is busy taking thread dump.Please try after some time.

Cause

The default number of agents to get thread dump is 25. If a new agent connected after this limit is reached, this error would be prompted.

Environment

APM 10.xWindows/linux/Unix

Resolution

Below are two solutions to adddress this error:

 1) Disable the thread dump feature for agents in which thread dumps are not needed. This can be achieved by setting the following properties in the in IntroscopeAgent.profile:

introscope.agent.threaddump.enable=false


2) Increase introscope.enterprisemanager.threaddump.perftune.cache property with appropriate value(upperbound 40) in IntroscopeEnterpriseManager.properties file of EM. An EM restart is required after making changes to this properties.

Note: The increase in this value would affect the performance of Introscope Enterprise Manager.