SystemEDGE does not respond to SNMP requests after ADES AIM is configured.
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SystemEDGE does not respond to SNMP requests after ADES AIM is configured.

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Article ID: 6623

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Updated On:

Products

CA Systems Performance for IM (SystemEdge) CA eHealth

Issue/Introduction

  • When the Active Directory and Exchange AIM (caesadaim) is configured SystemEDGE no longer responds to SNMP requests after it is started.
  • If ADES AIM configuration is cleared the agent starts working again.

Environment

Release: SYSPAG99000-5.7-Systemedge
Component:

Cause

  • SystemEDGE is hanging on startup since the XML Parser the ADES AIM uses is not present on the system.
  • The last entry in the sysedge.log is as follows:

[I]-26ac- caesadaim/caesadSysedge.cpp[117]: init(): Begin init

  • When manually running C:\Program Files\CA\SystemEDGE\plugins\caesadaim>caesadaim.exe the following is returned:

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or ass
embly 'System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c5
61934e089' or one of its dependencies. The system cannot find the file specified

 

 

 

 

Resolution

  • The ADES AIM uses the XML parser that is packaged with the full .NET framework installation package.
  • Installing the full .NET 3.5 SP1 Framework package will resolve this problem.

.NET 3.5 SP1 Cumulative Installer