Unable to connect to DB2 using Portal. Error: "HTTP Error - SERVICE UNAVAILABLE"
search cancel

Unable to connect to DB2 using Portal. Error: "HTTP Error - SERVICE UNAVAILABLE"

book

Article ID: 6618

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When attempting to connect to DB2 using the C:\Program Files\CA\CA Test Data Manager Portal\tomcat\jdbc-drivers\db2jcc4.jar driver, you receive the following error message in the log file: 

HTTP Error - SERVICE UNAVAILABLE: Could not load JDBC driver class [com.ibm.db2.jcc.DB2Driver]; nested exception is java.sql.SQLException

  • This connection works with Datamaker, but not in the Portal.
  • You tried to adding the common.jar and the db24jcclic.jar without success.
  • You have restarted the portal after dropping jar files into the tomcat jdbc-driver folder for each test.
  • You have also tested with these three jar files without success:
    • db2jcc4.jar
    • db2jcc4_license_cu.jar
    • db2jcc4_license_cisuz.jar

Environment

CA Test Data Manager (TDM)- Web Portal

Cause

You most likely do not have the jar file in the correct location.

The following forum discussions describe how Tomcat is loading the jar files:

Resolution

Copy the db2jcc4.jar file into your tomcat lib directory folder. By default, this is located at C:\Program Files\CA\CA Test Data Manager Portal\tomcat\lib. 

Additional Information

If you experience any further issues, open a support case at https://support.broadcom.com.