Unified Self-Service - "HTTP Status 500" when attempting to log in

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Article ID: 6554

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

With Unified Self Service (USS) integrated with EEM, when attempting to log in with any new user it will fail, existing USS users will be able to log without issue. The new user will not be created in USS database as expected and an error will be displayed in the browser similar to the one bellow:

"HTTP Status 500 - Servlet execution threw an exception"

The liferay log will not show any error, only the wrapper tomcat log will show details of it similar to the error message bellow:

INFO | jvm 1 | 2017/04/25 15:36:44 | Apr 25, 2017 8:36:44 PM org.apache.catalina.core.ApplicationDispatcher invoke
INFO | jvm 1 | 2017/04/25 15:36:44 | SEVERE: Servlet.service() for servlet Main Servlet threw exception
INFO | jvm 1 | 2017/04/25 15:36:44 | java.lang.StackOverflowError
....
INFO | jvm 1 | 2017/04/25 15:36:44 | at com.sun.proxy.$Proxy41.getLocale(Unknown Source)
INFO | jvm 1 | 2017/04/25 15:36:44 | at com.liferay.portal.kernel.language.LanguageUtil.getLocale(LanguageUtil.java:207)
INFO | jvm 1 | 2017/04/25 15:36:44 | at com.liferay.portal.language.LanguageResources.getSuperLocale(LanguageResources.java:103)
INFO | jvm 1 | 2017/04/25 15:36:44 | at com.liferay.portal.language.LanguageResources.getMessage(LanguageResources.java:86)
...

Cause

The portal-ext.properties file was set only to one locale,

# supported locale
locales=es_ES

Original line
#locales=de_DE,es_ES,fr_FR,it_IT,ja_JP,pt_BR,zh_CN,en_US,fi_FI,nl_NL,sv_SV,da_DA

The default locales that come with the application need to be loaded independently if they want or not be displayed in the USS Web interface, otherwise the application will not be able to create the user and along with it the user preferences.

Environment

Unified Self Service 14.1 or above integrated with EEM

Resolution

The original line of the locales should not be modified in the portal-ext.properties file, if it is required to change the default language of the site, modify it in the control panel->portal settings-> Display settings, select the language desired, and if required also remove the non desired available languages, then save the changes and log back in the application.

If it is only required to change the language of a single user, log in with the desired user go to My profile, edit the profile and set the language desired.

Attachments