When launching Support Automation UI, receive error message indicating application is blocked by Java Security.

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Article ID: 6510

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When launching Support Automation UI, receive error message indicating application is blocked by Java Security.

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Cause

Over the past couple of years, Oracle has implemented many security enhancements, features and requirements with their Java and JRE programs. 

This includes new security requirements which affect Rich Internet Applications such as Support Automation.

Environment

CA Service Desk Manager 12.9 and 14.1Support AutomationAll Supported Operating Systems

Resolution

Unfortunately this is not a Support Automation product issue, but an issue with the enhanced Java security. 

To address this issue with Support Automation, follow the instructions provided by Oracle under "Adding a site to the Exception Site List" at https://blogs.oracle.com/java-platform-group/entry/upcoming_exception_site_list_in.

Use http[s]://<Support_Automation_URL>:<port_number> as the URL for the RIA, where <Support_Automation_URL> is the fully qualified URL of your Support Automation and <port_number> is the port used by Support Automation (typically 8070 for Support Automation configured in a non-SSL configuration).

Additional Information

https://blogs.oracle.com/java-platform-group/entry/upcoming_exception_site_list_in

 

Attachments

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