During the IPL of z/OS 2.2, startup of CA COMMON SERVICES ENFSNMPM failed

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Article ID: 6489

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Updated On:

Products

CA CIS CA Common Services for z/OS CA 90s Services CA Database Management Solutions for DB2 for z/OS CA Common Product Services Component CA Common Services CA Datacom/AD CA ecoMeter Server Component FOC CA Easytrieve Report Generator for Common Services CA Infocai Maintenance CA IPC Unicenter CA-JCLCheck Common Component CA Mainframe VM Product Manager CA Chorus Software Manager CA On Demand Portal CA Service Desk Manager - Unified Self Service CA PAM Client for Linux for zSeries CA Mainframe Connector for Linux on System z CA Graphical Management Interface CA Web Administrator for Top Secret CA CA- Xpertware CA Compress Data Compression for MVS CA Compress Data Compression for Fujitsu

Issue/Introduction

During the IPL of z/OS 2.2, CA COMMON SERVICES TASK ENFSNMPM abended.

ENFSNMPM was successfully started a few minutes later.

 

 

Cause

TCPIP was not completely initialized, when ENFSNMPM was started.

This is illustrated by the following messages, from the output of the ENFSNMPM task: 

00:02:30 mainInit: CAW1030I: Resource temporarily unavailble. 

00:02:30 mainInit: Please wait 30 seconds. 

00:04:31 mainInit: node name 'JPNA' is not valid, getaddrinfo() rc=1 

00:04:31 MAIN: main_init return rc=4 

 

 

Environment

z/OS 2.2 CA COMMON SERVICES 14.1

Resolution

Automate the start of ENFSNMPM, using an automation product (like CA's OPSMVS)  to wait for TCPIP to become fully operational.

Key off TCPIP messages, from RESOLVER, such as

  • EZZ9291I RESOLVER INITIALIZATION COMPLETE 
  • EZAIN11I ALL TCPIP SERVICES FOR PROC TCPIP ARE AVAILABLE.. 

Additional Information

https://docops.ca.com/ca-common-services-for-z-os/14-1/en/administrating/event-notification-facility-caienf/snmp-monitor/start-stop-the-snmp-monitor