SD Jobs executed on target machine but they remain in status "Execution Order Staged"
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SD Jobs executed on target machine but they remain in status "Execution Order Staged"

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Article ID: 6358

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery

Issue/Introduction

The SD Jobs are executed on target machines but they remain in status "Execution Order Staged" in ITCM GUI.

If command "sd_sscmd bulkupdate" is manually executed on the Scalability Server, the SD Status are reported to the DOMAIN.

Why SD Status are not reported automatically and need a manual execution of bulk update ?

In the logs DSM\logs\TRC_USD_SDSERVER*.log in trace DETAIL

(set with : cftrace -c set -l DETAIL -s 30000 -f USD -pp SDServer )

A line like this one could not be found :

SDServer |SDServer |swjsscheduling.cpp |000719|INFO | Schedule Bulk Update now 

 

Environment

Client Automation - All Supported versions.

Cause

This problem could occur if "Bulk Update Mode" and "Stage Check Mode" are both enabled in the configuration policy applied on the Scalability Server under DSM/Software Delivery/Scalability Server :

 

When Stage Check and Bulk Update modes are enabled at the same time, the stage check interval takes precedence over the bulk update interval as described in the product online Help :

 

How SS Handles Messages—Bulk Update Enabled, Stage Check Enabled

When you configure the scalability server to run in both the modes, the stage check interval takes precedence over the bulk update interval, but the messages are sent in bulk. For example, if you configure the scalability server to perform stage check after every 60 minutes and bulk update after every 10 minutes, the scalability server sends the messages to the Installation Manager in bulk after every 60 minutes. The scalability server ignores the bulk update interval.

 

In this scenario, the scalability server handles the messages in the following manner:

  1. Scalability server caches the messages that it receives from the agents for a specified period (stage check interval). The scalability server ignores the bulk update interval. 
  2. Scalability server sends the messages to the Installation Manager when one of the following conditions is met: 

- When the scheduled time to perform the stage check has come, that is, at the completion of the stage check interval 

- When you manually force the stage check to take place by running the stagecheck command (sd_sscmd stagecheck) 

Note: For more information on the sd_sscmd stagecheck command, see the stagecheck section in the Software Delivery CLI Reference Guide.

- When you manually force the bulk update to take place by running the bulkupdate command (sd_sscmd bulkupdate) 

Note: For more information on the sd_sscmd bulkupdate command, see the bulkupdate section in the Software Delivery CLI Reference Guide. 

3. Scalability server sends the messages in bulk in the form of a single message, containing various submessages, to the Installation Manager. 

As the scalability server sends the messages to the Installation Manager in bulk, this scenario optimizes the database updates.

 

 

Resolution

The solution in order to have "bulk update" task executed is to disable stage check mode in the configuration policy applied on the Scalability server 

 

DSM/Software Delivery/Scalability Server/Stage Check: Run in stage check mode = False