Slow Login To Identity Manager
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Slow Login To Identity Manager

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Article ID: 6355

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

The login access to Identity Manager is very slow.  After login, we can access all IM tasks normally.

Environment

Identity Manager 12.5 SPx

Identity Manager 12.6 SPx

Cause

In our Identity Manager server DEBUG log, we found the following sql query taking long time to finish as we have a huge Task Persistence Database:

2017-04-12 15:23:00,281 DEBUG [ims.tmt.persistence.sql] (ajp-0.0.0.0-8009-6) PersistenceProvider: ajp-0.0.0.0-8009-6: conn: org.jboss.resource.adapter.jdbc.jdk5.WrappedConnectionJDK5@1b939d2 sql: select * from tasksession12_5 WITH (NOLOCK)  where environmentid = '2'  and (name <> 'View My Submitted Tasks')  and (name <> 'View Submitted Tasks')  and ({ fn LCASE(user_dn) } LIKE ? ESCAPE '\')   and (last_access_time >= ? )   and ((state = '2' )   or (state = '128' )   or (state = '256' )   or (state = '32' )   or (state = '1048576' ) )  and (acknowledged  <>  'Y' )  order by last_access_time DESC , created_time desc

The SQL query lags the login procedure as it's initiated by the home.jsp for presenting the 'Recently Completed Tasks' table on IM User Console Home page.

Resolution

Option 1:

  • Switch off the setting - 'Show Recently Completed Tasks' on Identity Manager Management console:
    Home › Environments › {IM ENV} › Advanced Settings › User Console 

Option 2:

  • Run the IM task - 'Cleanup Submitted Tasks' to clear up the Task Persistence Database