Finish date changes for some Team members after saving a project back from MSP to PPM
search cancel

Finish date changes for some Team members after saving a project back from MSP to PPM

book

Article ID: 6330

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The Available Finish date is changing for some resources when saving a project back from Microsoft Project (MSP) to PPM


Steps to Reproduce:

  1. Create a project in PPM
  2. Add one resource to the project with over 100 allocation segments
  3. Delete the Finish date for the resource from the team tab, which will reset the Finish date for the resource to the Project Finish Date
  4. Export the project from PPM to MSP
  5. Go to the Resource Sheet view in MSP, right click the resource and select 'Information' 
  6. Observe the values for the last 'Available To' date set under 'Resource Availability' (Also note, that there are only 100 rows, any allocation segments created over 100 do not get exported)
  7. Save the project back to PPM
  8. Navigate to the Team tab for the project and observe the Finish date for the resource

Expected Results: Finish date remains as the project finish date

Actual Results: Finish date changes to the Finish Date of the 100th allocation segment

Environment

Applies to all supported PAS environments for specified releases.

Cause

 This issue is due to a limitation with Microsoft Project. 

Resolution

Microsoft Project only allows 100 Availability Units per resource, any allocation segments after the 100th for a resource do not get exported to MSP. This results in the Finish Date for the resource being saved back to PPM as the 100th allocation segment / Availability Unit from MSP.

Workaround:

To prevent availability from changing when saving a schedule back to PPM, limit allocation segments to 100 or less in PPM.