Workload Automation Client access via Firewall
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Workload Automation Client access via Firewall

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Article ID: 6289

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Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

We have to access a workload server behind a firewall using the client. The necessary ports (7500/tcp, 7598/tcp & 7599/tcp) has been opened on the firewall. The server has a natted IP address. Once we try to connect to the server using the client, and specifying the NATED IP, the 2 initial connections are made on 7500 and 7599, but the connection to 7598 is on the servers non nated/correct ip. What configuration changes do we need to make so that we can access the server behind the firewall ?

Environment

CA Workload Automation DE - MULTI-PLATFORM Release:12.0

Cause

In a NAT or VPN environment, DNS entries have to be made for Desktop client to find the server or be in the client's hosts file. 

Then, you need to get the server to pass its hostname rather than its private IP.

Resolution

Add esp.java.rmi.server.hostname=<fully qualified host name> in server.properties config file and restart the server.