Can't start cluster after upgrade to 2.8.2
search cancel

Can't start cluster after upgrade to 2.8.2

book

Article ID: 6271

calendar_today

Updated On:

Products

CA Privileged Access Manager - Cloakware Password Authority (PA) CA Privileged Access Manager (PAM)

Issue/Introduction

After upgrading CA PAM cluster nodes to 2.8.2 an attempt to start the cluster failed with a "License Mismatch" error. But the licenses were checked and found to be the same on all cluster nodes.

Environment

Release:
Component: CAPAMX

Cause

In the list of cluster nodes the IPs and FQDNs of the individual nodes were entered. The problem is not observed when only IPs are used to specify the cluster nodes.

Multiple DNS servers from different subnets were configured on the Config > Network page. The server in the same subnet as the appliances was not on top of the list. This caused a name lookup to time out which in turn caused the primary node to fail to retrieve the license from the next cluster node, resulting in a license mismatch error.

Resolution

Reordering the DNS server list to put the one in the subnet of the cluster nodes on top resolved the problemĀ