Timeout in DMS API search.
search cancel

Timeout in DMS API search.

book

Article ID: 6245

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

Customer has written a custom application that implements the SSO DMS API.  Customer reports when performing a SmDmsSearch, the policy server is responding with error 

[facility=4 severity=3 reason=0 status=30 message=Timed out] 

After exactly one minute.  

 

Environment

All

Cause

The directory was taking longer than 60 seconds to perform the search.

Resolution

The customer resolved this issue by increasing the Maxtime parameter on the user directory.  Another method would be to look at why the directory was taking so long to perform the search.  It's possible the directory needed to be indexed for faster searching.