Symantec Identity Portal - WARN org.jgroups.protocols.pbcast.GMS / GMS
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Symantec Identity Portal - WARN org.jgroups.protocols.pbcast.GMS / GMS

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Article ID: 6231

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

When starting Identity Portal it is taking an extended period of time and the log is throwing warning messages concerning JGroup:

WARN org.jgroups.protocols.pbcast.GMS - ServerName-####: JOIN(ServerName-#####) sent to ServerName-#####2 timed out (after 3000 ms), on try 1

In vApp 14.4 CP2 this error looks like this:

WARN GMS - ServerName-####: JOIN(ServerName-#####) sent to ServerName-#####2 timed out (after 3000 ms), on try 1

Environment

Release : 14.X

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Component : CA IDENTITY PORTAL(IDENTITY PORTAL)

Cause

This is caused by orphaned data within the JGROUPSPING table. This orphaned data is caused by removing nodes within the cluster and the product does not clean up the JGROUPSPING table.

Resolution

For Standalone:

Stop Identity Portal

Purge all data within the JGROUPSPING table.

Start Identity Portal

Tail IP server logs and the error message should no longer show up.

For vApp

Stop Identity Portal "stop_ip"

Reconfigure "reconfigure_ip"

Start Identity Portal "start_ip"

Tail IP server logs and the error message should no longer show up.