Unified Self Service Integration Fails with Service Desk
search cancel

Unified Self Service Integration Fails with Service Desk

book

Article ID: 6229

calendar_today

Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

During install and configuration of Unified Self Service, the install may fail at the step in which it tries to integrate with Service Desk.

The install.Log is located in the USS server's %TEMP% directory.  In this file, the logs will say:

2017/03/01 12.14.35.252 DEBUG [DeployThread: Integrating the Products] [ConfigureOSOPWithSDM] Dataset update call completed. Response {"isSDMConfigEnabled":false,"Result":{"HTTPStatus":200,"message":"Request processed successfully","message_key":"HTTP_SUCCESS_MESSAGE"}} 

2017/03/01 12.14.35.253 WARN [DeployThread: Integrating the Products] [ConfigureOSOPWithSDM] CA Service Desk Manager Dataset not enabled. Retry: 1/10 

2017/03/01 12.15.01.222 DEBUG [DeployThread: Integrating the Products] [ConfigureOSOPWithSDM] Dataset update call completed. Response {"isSDMConfigEnabled":false,"Result":{"HTTPStatus":200,"message":"Request processed successfully","message_key":"HTTP_SUCCESS_MESSAGE"}} 

2017/03/01 12.15.01.223 WARN [DeployThread: Integrating the Products] [ConfigureOSOPWithSDM] CA Service Desk Manager Dataset not enabled. Retry: 2/10

...

2017/03/01 12.36.47.063 ERROR [DeployThread: Integrating the Products] [AutoIntegrateTask] Installation was success but one or more integration tasks failed, please see log for more details

 

Environment

CA Service Management 14.1, Unified Self Service, CA Service Desk Manager 14.1

Cause

The issue is being caused by the SDM Server's Tomcat either being disabled or inaccessible due to a configuration error.

In the same install.log as before, there may also be these entries present:

2017/03/01 12.08.13.705 DEBUG [AWT-EventQueue-0] [DatabaseManager] Product :9 KEY (sdm.webservices.url) Value (http://SDM-SERVER1:80/axis/services/USD_R11_WebService?wsdl) 

2017/03/01 12.08.13.783 DEBUG [AWT-EventQueue-0] [Configuration] sdm.webservices.url=>http://SDM-SERVER1:80/axis/services/USD_R11_WebService?wsdl 

2017/03/01 12.10.46.244 DEBUG [DeployThread: Integrating the Products] [Configuration] sdm.webservices.url=>http://SDM-SERVER1:80/axis/services/USD_R11_WebService?wsdl 

The above indicates that USS was trying to connect to SDM-SERVER1 via port 80.  This is incorrect as USS requires web services access, which by default is conducted via port 8080 (Tomcat).

Resolution

To address:

1) Log into USS as CASMAdmin (http://USS-SERVER:8686)
2) Click on the Gear icon on the left hand side, and choose Settings > Datasources > CA Service Desk Manager
3) Change the Base URL to: http://SDM-SERVER1:8080 instead of http://SDM-SERVER1:80
4) Save and Test Connection.

Also verify that the SDM Tomcat interface is accessible  One can do this by accessing on a web browser URL http://SDM-SERVER1:8080

Note:  Replace USS-SERVER AND SDM-SERVER1 with the appropriate server names.

Additional Information