RelayState/Deeplink not working
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RelayState/Deeplink not working

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Article ID: 6188

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

Although a RelayState (deeplink) value was included in the SP-initiated federation request, the user was brought to the default Target page for the SP application rather than the expected RelayState URL.

Environment

All current releases of Siteminder

Cause

This problem can have multiple causes.   

First, if the SP software is Siteminder, there is an option to allow the RelayState to override the Target.  By default this option is not selected.   

Second, the RelayState parameter name is case sensitive, and thus must appear just as it does in this document.  

Resolution

Assure that the SP software is configured to honor any RelayState values, and make sure the case is correct within the RelayState parameter name itself.