System Agent could not start reporting Corrupted objects.
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System Agent could not start reporting Corrupted objects.

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Article ID: 61506

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Updated On:

Products

Workload Automation Agent DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

Description:

How to resolve System Agent could not start issue, reporting Corrupted objects in defaultlog_agent.log file

Attempts to start the System Agent failed, and the defaultlog_agent.log file (located in the Agent log directory) reported 'Corrupted object' message as shown below;

-----------------------------------------------------------------------------------------------
Tue Mar 16 10:13:35.789 EDT 2010: CybAgentDriver - java.rmi.RemoteException:
cybermation.library.persistence.CybPersistenceException: Corrupted object
at cybermation.agent.communication.CybTCPIPControllerPlugin.<init>(Unknown Source)
-----------------------------------------------------------------------------------------------

 

Environment

Release:
Component: SYSAGD

Cause

This message indicates that the Agent database has been corrupted. The Agent database is corrupt if there exists .odb files containing truncated records.

There could be several reasons for the database corruption. For example, if the Agent process or service is killed instead of shutting it down gracefully or there is disk/file system problems on the Agent server.

 

Resolution

To resolve the problem, it is suggested to perform a cold start of the Agent by doing ANY of the following;

  1. Delete manually all files in the database folder (located in Agent installation directory), and re-start the Agent.

  2. Rename the database folder, and re-start the Agent. The database folder is created when the Agent is started.

  3. Set 'persistence.coldstart=true' parameter in agentparm.txt file, and re-start the Agent. The default is false.