Upgrade CA Service Desk Manager from 12.9 or 14.1 to 14.1.02 - missing jar files after the upgrade to 14.1 causes HealthServlet slow performance, "Not Running" status for pdm_intrvlog_nxd, and other problems
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Upgrade CA Service Desk Manager from 12.9 or 14.1 to 14.1.02 - missing jar files after the upgrade to 14.1 causes HealthServlet slow performance, "Not Running" status for pdm_intrvlog_nxd, and other problems

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Article ID: 6138

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

After upgrading CA Service Desk Manager from 12.x or from 14.1, to 14.1.02 (cumulative patch #2), you could encounter a situation whereby some ".jar" files are missing from the "bin" subdirectory of the CA Service Desk Manager base installation directory, $NX_ROOT\java\lib

Some symptoms that have been identified so far are as follows:

  1. The HealthServlet takes over 30 minutes to report back the status and reports that all is "OK".
     
  2. The output of pdm_status shows that "IntrvLogger (pdm_intrvlog_nxd)" is "Not Running".  It is not possible to start the Interval Logging process.
     
  3. It may not be possible to use Web Screen Painter

Environment

Upgraded CA Service Desk Manager 14.1 environment

Cause

A probable cause is that the ".jar" files were stopped from being copied onto the installation by a 3rd party antivirus or firewall program via corresponding rules or policies. 

The affected jar files may be limited to those included in cumulative patch #2 (14.1.02).

Resolution

  1. Check your anti-virus and firewall settings.  Disable or fix the settings so that all files that are required to be installed by the CA Service Desk Manager product installer and patch installer to the servers in the environment are not prevented from being installed, applied and run.
     
  2. If you have fixed the anti-virus, re-install the CA Service Desk Manager product and patches.
     
  3. Verify that the $NX_ROOT\java\lib directory contains the files listed below. 
     
    Notes:
    This list may only be a subset of the files that could have been missing when upgrading to 14.1.02.
    The list may be different if you upgraded to 14.1.03 or higher. 
    The timestamps of the files may be different in your environment, depending on your cumulative and test patch levels.

    06/01/2016  09:54 PM           285,523 BOPIntegration.jar
    06/01/2016  09:49 PM            41,123 commons-cli-1.2.jar
    06/01/2016  09:49 PM           263,965 commons-codec-1.9.jar
    06/01/2016  09:49 PM            36,888 commons-csv-1.1.jar
    06/01/2016  09:49 PM           185,140 commons-io-2.4.jar
    06/01/2016  09:49 PM            61,829 commons-logging-1.2.jar
    06/01/2016  09:55 PM           453,306 configui.jar
    06/01/2016  09:54 PM            88,611 DALbop.jar
    06/01/2016  09:55 PM           120,296 datapromotion.jar
    06/01/2016  09:57 PM            64,990 esEventHandler.jar
    06/01/2016  09:58 PM           294,230 GRLoader.jar
    06/01/2016  09:49 PM           232,482 gson-2.5.jar
    06/01/2016  09:49 PM           732,765 httpclient-4.5.1.jar
    06/01/2016  09:49 PM           326,594 httpcore-4.4.3.jar
    06/01/2016  09:49 PM            39,815 jackson-annotations-2.5.0.jar
    06/01/2016  09:49 PM            46,968 jackson-annotations-2.6.0.jar
    06/01/2016  09:49 PM           229,999 jackson-core-2.5.4.jar
    06/01/2016  09:49 PM           258,824 jackson-core-2.6.2.jar
    06/01/2016  09:49 PM         1,144,035 jackson-databind-2.5.4.jar
    06/01/2016  09:49 PM         1,167,351 jackson-databind-2.6.2.jar
    06/01/2016  09:49 PM            92,850 jackson-dataformat-xml-2.5.4.jar
    06/01/2016  09:49 PM            32,606 jackson-module-jaxb-annotations-2.5.4.jar
    06/01/2016  09:49 PM           865,400 jna-3.3.0.jar
    06/01/2016  09:49 PM           489,884 log4j-1.2.17.jar
    06/01/2016  09:49 PM           135,903 log4j-api-2.3.jar
    06/01/2016  09:49 PM           827,024 log4j-core-2.3.jar
    06/01/2016  09:49 PM         3,725,989 ojdbc7.jar
    06/01/2016  09:56 PM            19,047 pdm_intrvlog_nxd.jar
    06/01/2016  09:54 PM             6,413 pdm_logo_util.jar
    06/01/2016  09:56 PM             4,864 pdm_picture_util.jar
    06/01/2016  09:57 PM            83,450 pdm_rest_util.jar
    06/01/2016  09:56 PM           272,453 sdmp.jar
    06/01/2016  09:56 PM            11,717 secondary-config.jar
    06/01/2016  09:57 PM           123,370 slump.jar
    06/01/2016  09:49 PM           161,867 stax2-api-3.1.4.jar
    06/01/2016  09:58 PM           473,564 WebScreenPainter.jar
     
  4. For future prevention of a similar problem, be sure to use the same antivirus/firewall settings for installing cumulative patches and test patches of CA Service Desk Manager as for installing the base product. 

Additional Information

TEC581795 Anti-Virus recommendations for CA Service Desk Manager (SDM)