vmware probe data collection error after startup - Unexpected fatal error in data collection
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vmware probe data collection error after startup - Unexpected fatal error in data collection

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Article ID: 6097

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) Unified Infrastructure Management for Mainframe

Issue/Introduction

vmware probe data collection error after startup

We attempted to deploy the VMware probe to a VCenter server. We were able to configure it to connect to the VMware API successfully and it discovers all of the components of the VMware environment (i.e. ESX hosts, datastores, etc...). However, shortly after it starts running, we get the following error message:

"<hostname> is not responding (reason: Unexpected fatal error in data collection. Collection will not resume until probe is restarted. See log for details.)"

Environment

  • Any supported UIM version 
  • vmware probe v6.72 or later
  • Windows Server 2012 R2 Standard

Cause

- The out of the box vmware java heap memory parameters were too low.

Resolution

In the vmware.cfg, startup->opt section showed:

<startup>
   options = -Xms32m -Xmx512m -Duser.language=en -Duser.country=US
</startup>

To resolve this issue follow the steps below:

1. Using Raw Configure, increase the java heap memory to:

<startup>
options = -Xms2048m -Xmx4096m -Duser.language=en -Duser.country=US
</startup>

2. Click Ok/Apply


3. Cold Start the probe (Deactivate-Activate)


4. Check the log again to make sure the error has been resolved.