After removing a hub from the environment I am still seeing the discovery Server trying to contact the now missing discovery Agent and presenting and error in the discovery_server.log. How do I correct it?
search cancel

After removing a hub from the environment I am still seeing the discovery Server trying to contact the now missing discovery Agent and presenting and error in the discovery_server.log. How do I correct it?

book

Article ID: 6093

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After removing a hub from the environment I am still seeing the discovery Server trying to contact the now missing discovery Agent and presenting and error in the discovery_server.log. How do I correct it?

 

Error seen in logs:

Line 8081: 20 Mar 2017 23:17:34,239 [daConfigWorker-1] WARN com.nimsoft.discovery.server.agent.config.DiscoveryAgentConfigUpdater - discovery agent may not be running, config not sent to /<DOMAIN>/<HUB>/<Robot>/discovery_agent.

Environment

UIM 8.51But could be in any environment 7.x or 8.x environment

Cause

This is caused by left over data in the environment referencing the now missing discovery_agent.

Resolution

1) delete the <nimsoft>\hub\hub.sds from the primary
2) run the following query on the UIM database
delete from CM_DISCOVERY_AGENT where robot ='<robotname from error>'
3) deactivate the discovery_server remove the current logs then activate it.