pdm_d_mgr fails on PDM_Configure
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pdm_d_mgr fails on PDM_Configure

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Article ID: 60808

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

When running pdm_configure, the configure.log may indicate "Access is denied".  stdlog may also report the same, especially when trying to create/configure users.

pdm_d_mgr           2372 ERROR pdm_d_misc.c        293 Access is denied. 
pdm_d_mgr           2372 ERROR mgr_os_if.c        1107 Could not open Service Control Manager


Above logs are stored in NX_ROOT\log

When running the command "pdm_d_mgr -h" from an admin command prompt, which should generate a help page for the command and make no changes, but it also returns "Access is denied".  

Environment

Release:  All releases
Component: CA Service Desk Manager

Cause

Increased security feature from User Account Control (UAC) or third party security products can cause the Service Desk Configuration program to fail since the application cannot access the Services Control panel directly.

Resolution

You need to disable UAC or any third party security products such as virus scanners in order for the Service Desk Configuration program to complete successfully.

  1. Launch MSCONFIG from the Run menu.
  2. Click on the Tools tab. Scroll down till you find "Disable UAC" and select that line.
  3. Press the Launch button.
  4. A CMD window will open. When the command is done, you can close the window.
  5. Close MSCONFIG.
  6. You need to reboot the computer for changes to apply.
  7. Re-run the Service Desk Configuration program after the server has restarted.

Additional Information

Check also that the logged in user has permissions to run such commands.  See KB Article 53662 for further information on user permissions needed.

Broadcom Support is not permitted to assist in the configuration of any security settings on your servers.  You will need to review such settings with your local security or system admins.