When performing tasks in Identity Manager, you may encounter an ORA-12899 error indicating that a value is too large for a database column. This occurs when the data being stored in the Task Persistence Database exceeds the character limits defined in the schema for a specific column.
Identity Manager 14.5
This error is triggered when the length of the string generated by an Identity Manager task (such as a custom attribute or task name) exceeds the maximum length configured for the corresponding column in the Task Persistence Database. While this error is specific to Oracle databases, similar overflow errors may occur in other database types.
To resolve this issue, increase the storage capacity of the affected database column. Coordinate with your Database Administrator (DBA) to perform the following steps:
ORA-12899: value too large for column "[TABLE NAME]"."[COLUMN NAME]").ALTER TABLE SQL script to increase the maximum size of the identified column (e.g., increasing varchar(50) to varchar(200)).To speak with a customer representative or a Support Engineer see . Scroll to the bottom of the page and click on your respective region.