SOI manager takes extremely long time to startup

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Article ID: 6024

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

When starting up SOI manager services, it is taking extremely long time and still in the initializing status.

In the $SOI\tomcat\logs\soimgr-debug.log, if you found the following messages, and the numbers in the messages keep increasing, then this KB article is applicable for you.

INFO [JobQueue Monitor] thread.JobQueue$MonitorThread.run(99) - 2460s 21:50ms ServletInit

INFO [JobQueue Monitor] thread.JobQueue$MonitorThread.run(99) - 2520s 21:50ms ServletInit

INFO [JobQueue Monitor] thread.JobQueue$MonitorThread.run(99) - 2580s 21:50ms ServletInit

INFO [JobQueue Monitor] thread.JobQueue$MonitorThread.run(99) - 2640s 21:50ms ServletInit

 

Cause

In SOI version 3.x, 4.0 and 4.0 CUM1, if the SOI services are not shutdown normally, the SOI correlation cache files will be deleted from the system. Whenstarting SOI services, without having these correlation cache files, SOI services will run through the whole SAMStore Database to search for inconsistencies and clean our those inconsistencies. This is why it is taking very long time to start up SOI manager services.

This issue has been addressed in the SOI 4.0 SP2 version.

Environment

SOI 3.x, 4.0, 4.0 CUM1,

Resolution

You will need to wait patiently for SOI manager services to complete the initialization process and startup. 

Alternatively,  if you upgrade to SOI 4.0 Sp2, this problem will be addressed.