"AHD04042 login time out", java.net.SocketException at startFastChannel, ERROR SLUMP timed out attempting to connect fast channel to web:local webengine
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"AHD04042 login time out", java.net.SocketException at startFastChannel, ERROR SLUMP timed out attempting to connect fast channel to web:local webengine

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Article ID: 5998

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

On the first attempt to log into the CA SDM web interface after the CA Service Desk Manager (SDM) service is started on a server, the login fails and all of the following symptoms may occur at the time of failure:

  1. In the web browser: "AHD04042:Login failed for userid (ServiceDesk); login timed out".
     
  2. In "pdm_tomcat_nxd.log":
     
    Feb 24, 2017 4:03:30 PM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 1861 ms
    java.net.SocketException
    at com.ca.ServicePlus.pdmweb.SLUMPTC.startFastChannel(SLUMPTC.java:908)
    at com.ca.ServicePlus.pdmweb.SLUMPTC.initSlump(SLUMPTC.java:391)
    at com.ca.ServicePlus.pdmweb.SLUMPTC.run(SLUMPTC.java:944)
    Feb 24, 2017 4:08:20 PM org.apache.catalina.core.StandardServer await
    INFO: A valid shutdown command was received via the shutdown port. Stopping the Server instance.
     
  3. In "jsrvr.log":
     
    02/24 16:04:46.320[Thread-7] INFO SLUMPTC 386 Logon to Slump:pdmweb:INP44XPAPP972#5e9f143f:15a6faecc0e:-7fff
    02/24 16:04:46.321[TCP_port-Read:Slump_nxd] INFO TCP_port 229 Created fastchannel port 2120 for null with id 1487932486321 between 1936611614.pdmweb:SDMWINAA01#5e9f143f:15a6faecc0e:-7fff and 9398.web:wsp
    02/24 16:04:46.330[TCP_port-Read:Slump_nxd] INFO SLUMP 742 Using normal channel for connection with: web:local
    02/24 16:06:16.329[Thread-7] ERROR SLUMP 340 Timed out attempting to connect fast channel to web:local
    02/24 16:06:16.329[Thread-7] INFO SLUMPTC 403 Failed to logon to slump. Please check server daemon
     
  4. In "stdlog.<x>", the associated messages show Tomcat was started more than 5 seconds before the domsrvr initialization had completed.

    For example, domsrvr initialization completes over 90 seconds after Tomcat is started:
     
    02/24 16:03:28.44 <SERVERNAME> pdm_tomcat 1132 SIGNIFICANT pdm_tomcat.c 1373 Starting SERVICEDESK Tomcat
    02/24 16:05:10.37 <SERVERNAME>domsrvr 3328 SIGNIFICANT top_ob.c 1024 Domsrvr initialization is complete 
     

Environment

CA Service Desk Manager 14.1, 17.X

Cause

An out-of-the-box environment is configured to wait only 5 seconds after the domsrvr has connected to the slump process before Tomcat is started, and this amount of delay may not be enough in some environments.  Tomcat should only be started after domsrvr has completed initialization.

Resolution

As a short-term solution, you could run the following commands, consecutively, on the server:

pdm_tomcat_nxd -d stop

pdm_tomcat_nxd -d start

For a long-term solution, determine the difference in timestamps between the messages described in symptom #4.  And, then, configure a delay time that is longer than the difference. 

To configure the delay, modify the pdm_startup file as follows:

  1. Find the section that starts with:
     
    PDM_TOMCAT_CONTROLLER(pdm_tomcat, $NX_LOCAL_HOST, "pdm_tomcat-%h" )
     
  2. In an out-of-the-box environment, the next line would contain this statement:
     
    after domsrvr connects + 5
     
  3. Change "after domsrvr connects + 5" to "after domsrvr connects + 120". Alternatively, instead of 120 seconds, set a value for the number of seconds that is slightly higher than the earlier-computed timestamps difference.

For the change to persist, be sure to make the same modification to the pdm_startup.tpl file.

After configuring the pdm_startup file, recycle the CA Service Desk Manager services.  Do this on each affected CA SDM server in the environment.  Be sure to recycle according to the requirements of the appropriate configuration type: Conventional (primary, secondary) or Advanced Availability (background, standby, application). 

 

Additional Information

The pdm_startup and pdm_startup.tpl files are located in the $NX_ROOT\pdmconf directory. 

The pdm_tomcat_nxd, jsrvr.log, and stdlog.<x> files are located under $NX_ROOT\log.

$NX_ROOT is a notation for the base CA Service Desk Manager installation director; the default for $NX_ROOT in a Windows environment is ""C:\Program Files (x86)\CA\Service Desk Manager".