Data Protection - Upgrading the reports package on the CMS fails.
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Data Protection - Upgrading the reports package on the CMS fails.

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Article ID: 5991

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Updated On:

Products

CA Data Protection (DataMinder)

Issue/Introduction

When upgrading the reports package (reports.msi) on the Data protection (DataMinder) CMS the install may fail with an access denied error like the one below.

 

Error 25221. Error installing reports : Unable to connect to the database. (code 0xe563f409). Description: 'Failed to connect to data source : java.sql.SQLInvalidAuthorizationSpecException: [CA DataMinder][Oracle JDBC Driver][Oracle]ORA-01017: invalid username/password; logon denied 

 

The full error reported in the MSI logs (where verbose logging is enabled) appears as per the example below:

 

WGN: Command '"C:\Program Files (x86)\CA\CA DataMinder\system\wgninfra.exe" -exec wigan/schema/Schema RunScript' completed with status 0xe563f409. 

WGN: Extended error 'Failed to connect to data source : java.sql.SQLInvalidAuthorizationSpecException: [CA DataMinder][Oracle JDBC Driver][Oracle]ORA-01017: invalid username/password; logon denied'. 

WGN: Install reports completed with status 0xe563f409. 

Error 25221. Error installing reports : Unable to connect to the database. (code 0xe563f409). Description: 'Failed to connect to data source : java.sql.SQLInvalidAuthorizationSpecException: [CA DataMinder][Oracle JDBC Driver][Oracle]ORA-01017: invalid username/password; logon denied 

Environment

CA Data Protection (DataMinder) all versions running on an Oracle backed CMS

Cause

This issue is caused by invalid database credentials assigned to the WGNOWNER and WGNREPORTING user accounts. These user accounts are not used with daily application usage but are used during the install. 

Resolution

To address this issue confirm or reset the login credentials for these user accounts on the Oracle Database end and then update them in the Data protection (DataMinder) application using the steps below. 

 

1. Stop the Data Protection (DataMinder) Infrastructure service. 

2. On the CMS machine open a Command (Cmd) window and change directory to the Data Protection system folder (i.e. cd \%wgninstalldir%\system) where the 'wgninfra.exe' binary is located. 

3. Reset the owner ( default user - WGNOWNER ) password using the syntax below: 

wgninfra.exe -exec wigan/schema/Schema SetUser owner <SCHEMA OWNER> <new password> 

 

For example:

wgninfra.exe -exec wigan/schema/Schema SetUser owner WGNOWNER MyP@ssword 

 

4. Reset the reporting ( default user - WGNREPORTING ) password using the syntax below: 

wgninfra.exe -exec wigan/schema/Schema SetUser reporting <REPORTING USER> <new password> 

 

For example:

wgninfra.exe -exec wigan/schema/Schema SetUser reporting WGNREPORTING MyP@ssword 

 

5. Restart the Infrastructure service after executing the commands. 

6. After updating the passwords proceed with the installation. 

 

Additional Information

Notes: 

a. Modifying database accounts may impact the usage of the Data Protection (DataMinder) system.  Please ensure that you have read all the instructions and validated all information before proceeding.  If you have any concerns please contact CA Technical Support before proceeding.

b. Early releases of this product (i.e. Orchestria\ CA DLP) used a naming convention of prefixing user account with APM.  For example APMOWNER, APMREPORTING, etc.  Some of these naming conventions may have persisted through upgrades.  New deployments use a naming convention of prefixing user account with WGN.  For example WGNOWNER, WGNREPORTING, etc.  You are advised to check the user accounts deployed at the Database and use the correct account names in the commands above.

c. The above commands _ARE_ case sensitive.

d. <new password> in the above commands represent the corresponding Oracle db password associated with the user account (i.e. WGNOWNER).