Custom written ITPAM workflow process does not trigger the email for only 1 contact in CA Asset Portfolio Management.
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Custom written ITPAM workflow process does not trigger the email for only 1 contact in CA Asset Portfolio Management.

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Article ID: 5985

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

We have developed a custom Process Automation process that triggers an email notification 30 days prior to the legal document termination date. 

The notification is working for all contacts, except it will not work for one contact. 

Environment

CA Asset Portfolio Management 14.1

Cause

Investigation showed there were two contacts in the system with the same first name, last name, and userid. 

One of the contacts did not contain an email address.  

When triggering the event by changing the asset contact owner field, the contact without an email address had been chosen, rather than the contact that had a valid email address. 

Resolution

The problem was resolved by removing the contact that did not have an email address.