Have installed CASpool on a new LPAR. Successfully ran all the verification steps in the Installation Guide, except I can not contact TCP/IP printers.
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Have installed CASpool on a new LPAR. Successfully ran all the verification steps in the Installation Guide, except I can not contact TCP/IP printers.

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Article ID: 5902

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Updated On:

Products

Spool

Issue/Introduction

Receiving the following error messages trying to print to a TCP/IP printer on a new environment:

ESF911 File nn on printer xxxxx - Unable to connect to foreign host. EDC8130I Host cannot be reached.

ESF913 File nn on printer xxxxxx - Session request timed out 

ESF926 Printer xxxxxxx edrained 

Environment

CA Spool; z/OS; TCP/IP printers

Cause

This problem may occur when there is more than one TCP/IP stack on the system. CA Spool may be binding to the wrong TCP/IP stack instead of the one that allows the network access to this printer.
Any other network or printer errors that prevent the connection may cause these messages.

Resolution

When there are multiple TCP/IP stacks on a LPAR, establish a TCP/IP stack affinity to a desired stack. Establishing a stack affinity binds all socket communications to that stack.

To select a particular TCP/IP stack, include the following JCL statement to execute the BPXTCAFF program in the CA Spool startup JCL, before the step that executes the program ESFMAIN:

//AFFINITY EXEC PGM=BPXTCAFF,PARM=stackname

If the multiple stack is not the problem then it can be another network or printer problem that is preventing the connection.

 

Additional Information

Installing CA Spool - Add the JCL Procedure