AgentAPI has init() process latency issue
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AgentAPI has init() process latency issue

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Article ID: 5881

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

When AgentAPI call init() process and try to connect with Policy Server, some more latency issue have been occurred.

Is there any way which can reduce this interval ?

Environment

Release:
Component: SMSSO

Cause

In default, AgentAPI takes 6000 milliseconds at maximum for init() process, and maximum retry number is 5 times.

Resolution

Execute java command and tune retry interval.

e.g ) java -DNONBLOCKING_CONNECTION_SLEEP_TIME=1000

 

Additional Information

Pure Java AgentAPI Performance Issues (181112) :

https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/release-notes/known-issues-in-release-12-52-sp1/sdk-known-issues#SDKKnownIssues-PureJavaAgentAPIPerformanceIssues(181112)