NullPointerException occurs in View Submitted Tasks

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Article ID: 5812

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

When using the Bulk Loader or Bulk Task to submit Modify User tasks, those tasks are completed successfully and the users updated, but when trying to view the task details in View Submitted Tasks, a java.lang.NullPointerException is displayed on screen and in the log file.

Cause

This can occur if "Allow custom column" is enabled for the View Submitted Tasks task, but no custom column name is specified.  

Environment

Release:
Component: IDMGR

Resolution

To resolve the error, modify the View Submitted Tasks task as follows: 

1. Select the View Submitted Tasks task to modify, then click Tabs, and edit the Submitted Tasks tab. 

2. Uncheck "Allow custom column". 

3. Submit the change.