SD Catalog Error: SD Error Code:42

book

Article ID: 5791

calendar_today

Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

Unable to connect to SD Catalog. Error: SD Error Code: 42

Connection to server not possible. The machine has not completed its registration with the Domain Manager.

The agent has not completed its registration with Domain Manager. Please check the event log for more details, and make sure that the agent FIPS mode is compatible with that of the scalability server and domain manager.

Cause

The issue is caused when agent machine has not completed its registration with the Domain Manager.

Environment

Applicable for all version of CA Client Automation.

Resolution

Catalog get the available software by connecting to the manager. If the manager address is not available then the catalog fails.

We can run the below command to determine if the Manager address is available for the agent. 

ccnfcmda -cmd getparametervalue -ps itrm/agent/units/. -pn currentManageraddress 

If the command returns CCNF_PARAMETER_NOT_FOUND then set the manager address appropriately as below. 

ccnfcmda -cmd setparametervalue -ps itrm/agent/units/. -pn currentManageraddress -v <Manager Address>