Error 99: igateway service failed to start
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Error 99: igateway service failed to start

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Article ID: 57636

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Updated On:

Products

Autosys Workload Automation CA eHealth CA Service Desk Manager

Issue/Introduction

The EEM service iTechnology iGateway starts. However, the "igateway -b" daemon stops immediately after the start.

root     29905     1  0 17:45 pts/1    00:00:00 /bin/sh ./WDigateway.sh

The Following error is captured in file $IGW_LOC/igateway.log (/opt/CA/SharedComponents/iTechnology/igateway.log)   
[1450498928] 07/14/15 12:45:20 FATAL :: main: Server failed to start
[1450498928] 07/14/15 12:45:31 ERROR :: SyncTCPConnAcceptor::start : unable to start acceptor on port [ 0 , errno: 99 ]
[1450498928] 07/14/15 12:45:31 ERROR :: SyncTCPListener::startConnectors : connector for port [ 0 ] failed to start and mustlisten set to true
[1450498928] 07/14/15 12:45:31 ERROR :: SyncTCPListener::start : unable to start connector/s
[1450498928] 07/14/15 12:45:31 ERROR :: TCPTransportReceiver::start : transport receiver [ TCP ] failed to start
[1450498928] 07/14/15 12:45:31 ERROR :: TransportReceiverHandler::start : transport receiver [ TCP] failed to start
[1450498928] 07/14/15 12:45:31 FATAL :: Server::startReceivers : Unable to start receiver [ TCP ]
[1450498928] 07/14/15 12:45:31 FATAL :: Server::startReceivers : unable to start server

[1450498928] 07/14/15 12:45:31 ERROR :: Server::start : Receivers didnot get started as expected

[1450498928] 07/14/15 12:45:31 FATAL :: main: Server failed to start

Environment

EEM
12.51, 12.6 and higher 

Cause

The "errno: 99" means that the application is not able to create a socket connection.

The causes for socket creation failure can be various, depending upon the OS, the firewall configuration, the ports not being enabled, the IPC has certain problems which are beyond CA’s scope of effort, and any other environment related problems, etc.

Resolution

Note:
Some times hostname and FWDN will not work and IP address must be sued.

1.  
Stop the EEM related services

a.   iTechnology iGateway

2.   Go to the $IGW_LOC location. This is the location where iTechnology iGateway is installed.

3.   Open the igateway.conf file for editing

a.   Change the bind-address value from localhost to IP Address/hostname in “TCPListener” connector.

        <TransportReceiver imageName="TCPListener" name="TCP">

                <implementation>synchronous</implementation>
                <Connector name="secure_safetynet">
                        <bind-address>IP Address/Hostname</bind-address>
                        <port>0</port>
                        <mustlisten>true</mustlisten>
                        <conntype>secure</conntype>
                        <conntimeout>86400</conntimeout>
                        <maxconnections>100</maxconnections>
                        <maxrequestbytes>10000000</maxrequestbytes>
                        <maxpiperequests>100</maxpiperequests>
                </Connector>

b.   If after changing this the same problem still occurs, then change the bind-address in the “safetynet” connector from localhost to IP Address/ Hostname

                <Connector name="safetynet">
                        <bind-address>IP Address/Hostname</bind-address>
                        <port>0</port>
                        <mustlisten>true</mustlisten>
                        <conntype>insecure</conntype>
                        <conntimeout>86400</conntimeout>
                        <maxconnections>100</maxconnections>
                        <maxrequestbytes>10000000</maxrequestbytes>
                        <maxpiperequests>100</maxpiperequests>
                        <maxAcceptRate/>
                </Connector>

 

4.   Save the file and start the iTechnology iGateway

Additional Information

NOTE:
Make sure SELinux is disabled or set to permissive mode.
(If help is needed in doing this please contact your OS admin or vendor)

If the EEM policy were not created please follow the below KB.
Enable EEM security for AutoSys