TIRM629E Error : Client Manager Could Not Send Data to Server
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TIRM629E Error : Client Manager Could Not Send Data to Server

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Article ID: 5763

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Updated On:

Products

Gen Gen - Workstation Toolset Gen - Host Encyclopedia Gen - Run Time Distributed

Issue/Introduction

                                                 Ways to Resolve TIRM629E Errors

 

                Middleware TCP/IP Direct Connect Client/Server Cooperative Processing.

 

Environment

Using TCP/IP Direct Connect for CICS z/OS Single Socket Server ListenerMulti Socket Server Listener

Cause

Timeout values in EZACONFG or User Exits not set properly for site volume and/or application requirements.

Resolution

                                                

1.  1.  Get up-to-date with maintenance affecting the Single Socket Server Listener (TISL, TISRVLIS) and Multi Socket Server Listener (TIML,     TISRVMSL).  For Gen 8.5, verify the following PTF’s are applied:

    RO77382    RO90347    RO90348    RO93637

    These PTF's are inclusive in Gen 8.6 and no new PTF's for Gen 8.6 at the time of this KD.

 

2.  Increase the timeout value in the user exit CEHBSAMP(TIRSIPEX) to 1 as follows:

FROM:

002490 01  WORK-TIME-VALUE.                                                                                   0000930

002500     03  WORK-SELECT-SECS-DEF     PIC 9(8) BINARY VALUE 0.                          0000940

002600     03  WORK-SELECT-MICROSEC-DEF PIC 9(8) BINARY VALUE 000100.              0000950

 

   TO:

002490 01  WORK-TIME-VALUE.                                                                                  0000930

002500     03  WORK-SELECT-SECS-DEF     PIC 9(8) BINARY VALUE 1.                         0000940

002600     03  WORK-SELECT-MICROSEC-DEF PIC 9(8) BINARY VALUE 000100.              0000950

To install, use MKUEXITS for COBOL 4.x or MK5EXITS for COBOL 5.x and above.  

 

3.   If using the Single Socket Server Listener (TISL, TISRVLIS), move to the Multi Socket Server Listener (TIML, TISRVMSL).

4.   Increase the retires for the 629 error in client exit CICMCLX.c and install with CCMEXIT.NT.   See docopts.ca.com in the User Exit Guide for installation instructions.

5.  Otherwise open a support case and provide a CMIDEBUG.