SpectroSERVER will not start. Unable to bind to port 48879 seen in VNM.OUT file.
search cancel

SpectroSERVER will not start. Unable to bind to port 48879 seen in VNM.OUT file.

book

Article ID: 57556

calendar_today

Updated On:

Products

Spectrum

Issue/Introduction

SpectroSERVER will not start. Unable to bind to port 48879 seen in VNM.OUT file.

Environment

Release: Any
Component:

Cause

There is another program/application using port 48879. The SpectroSERVER needs to bind to port 48879 to run. 

Resolution

Shutdown all the Spectrum programs and run the netstat command as follows to find the program/application that is using port 48879.

Linux

1. Log into or su to the root user

2. Enter the following command:

netstat -anp | grep 48879

3. The output will look similar to the following where 54349 is the process ID and SomeProgram is the process name:

tcp        0      0 1.2.3.4:48879        4.3.2.1:45155        ESTABLISHED 54349/SomeProgram


Windows

1. Log into the system as the user that owns the Spectrum installation

2. Start a bash shell by running "bash -login"

3. Enter the following command:

netstat -ano | grep 48879

4. The output will look similar to the following where 1396 is the process ID

TCP    1.2.3.4:1643     4.3.2.1:48879    ESTABLISHED     1396


Once the program/application has been identified, shutdown/restart the program/application. Rerun the same netstat command to verify port 48879 is not being used. Then start the SpectroSERVER as normal.