The Primary SpectroSERVER crashes on Windows during the Online Backup with SPC-SHD-29021 error message in the VNM.OUT file.
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The Primary SpectroSERVER crashes on Windows during the Online Backup with SPC-SHD-29021 error message in the VNM.OUT file.

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Article ID: 57347

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

The Primary SpectroSERVER crashes on Windows during the Online Backup with SPC-SHD-29021 error message in the VNM.OUT file.

SPC-SHD-29021: 
**************************************************************************
The following output is intended to facilitate debugging, please forward
to CA technical support.  The files listed are not part of the customer
installation of SPECTRUM.
**************************************************************************

Jan 15 19:00:05 ERROR TRACE at CsSSDbRp.cc(722): unspecified database engine error  (close failure)  @  TableImpl.cc:189
      (0xffff86e9)  Db::close: Unknown error
Error:  Failed to copy database files.  The database is open.
An application fault has occurred.

Environment

Release: Any version of Spectrum running on Windows
Component:

Cause

The database files are currently locked by another process other than a Spectrum process.

Resolution

  • Check for disk backup and/or anti virus software. If installed, exclude the $SPECROOT directory so it does not interfere with the Spectrum processes.
  • Verify there is sufficient memory allocated to the Operating System where Spectrum Server is running a low memory condition can also trigger this crash during online backup.

Additional Information

Please reference the "Antivirus Software and Backup" section of the documentation for more information.

Antivirus Software and Data Backup

CA Spectrum does not include antivirus software. We recommend installing your preferred antivirus software to protect your networking environment.

Important! To avoid database corruption, exclude CA Spectrum installation areas and CA Spectrum files from scans by any local or remote instances of antivirus software. CA Spectrum installation areas include OneClick and Report Manager installation areas.

Exclude all CA Spectrum installation areas, including OneClick and Report Manager installation areas, from scans by data backup programs.