Failed to successfully log into the OneClick server when installing Spectrum connector for SOI.
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Failed to successfully log into the OneClick server when installing Spectrum connector for SOI.

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Article ID: 5734

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

When installing Spectrum connector for SOI, if Spectrum OneClick has enabled SSL and you have already imported the keystore from OneClick server to Spectrum connector server. Also make sure the OneClick credential you have entered during the installation is correct. You are getting the following error in the screen capture during the installation.

<Please see attached file for image>

Capture.PNG

Please open CA-Spectrum_Connector_InstallDebug.log, if you saw the 

Environment

Spectrum connector version: 2.0.0.xxxSOI 3.x, 4.xSpectrum 10.x

Cause

In Spectrum 10.x, Spectrum uses TLS protocol to communicate through SSL and Spectrum connector uses SSLV3 for communication. This is why the communication has been blocked between OneClick and Spectrum connector. 

Resolution

1. Please go to Spectrum OneClick server, open $SPECROOT\tomcat\conf\server.xml file.

 

2. Find the "Connector" session in the file, replace sslProtocol="TLS" with sslEnabledProtocols="TLSv1,TLSv1.1,TLSv1.2,SSLv2Hello,SSLv3".

3. Below is what it should look like after you make the change for the "Connector" session.

<Please see attached file for image>

src="/servlet/servlet.FileDownload?file=0150c000004AKQeAAO" alt="Capture 2.PNG" width="1109" height="132">

4. Please restart Spectrum tomcat service.

5. Run the installation for Spectrum connector again.

 

Attachments

1558707912009000005734_sktwi1f5rjvs16qvt.png get_app
1558707909919000005734_sktwi1f5rjvs16qvs.png get_app