Spectrum users see error about high console memory usage
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Spectrum users see error about high console memory usage

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Article ID: 57325

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Some Spectrum users are getting: "It is advised you contact Spectrum Administrator to increase client memory limits.  Console memory has hit critical threshold of 95%.

Environment

Release: Any
Component:

Cause

The MIN/MAX OneClick Client memory settings are too low for your Spectrum installation.

Resolution

Increase the MIN/MAX OneClick Client memory settings:

1. Log into the OneClick web page as an ADMIN user

2. Click on the Administration link

3. Click on the OneClick Client Configuration link

4. Increase the MIN/MAX Client Memory values by 50% as a start to see if that resolves the issue.

The change is saved in the $SPECROOT/custom/common/config/custom-jnlp-config.xml file on the OneClick web server machine.

You will have to click on "Start Console" to download the updated oneclick.jnlp file and launch it.

To confirm the changes, you can open the downloaded oneclick.jnlp file with NotePad++ (or any Text File Editor) and see this entry:

    <j2se version="11.0.20_00+" java-vm-args="--add-opens=java.base/javax.crypto=ALL-UNNAMED" href="http://java.sun.com/products/autodl/j2se"
          initial-heap-size="1024m" max-heap-size="4096m"/>

Where max-heap-size="4096m" is the "Maximum Client Memory Usage".

NOTE: Care must be taken when increasing the Client Memory values. The client must have the configured memory available on their workstation to log into OneClick. Increasing the values too high may result in some clients not being able to log into OneClick.

Additional Information

Please reference the "Configure OneClick Client Memory Settings" section of the documentation for more information.