Identity Manager Jboss IO Error

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Article ID: 5711

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

We are seeing the error "java.io.EOFException" Inside the jboss application server logs. The entire error looks similar to this

ERROR [ims.tmt.persistence] (Thread-15 (HornetQ-client-global-threads-21606282)) PersistenceProvider: JMS:ID:7a915ca0-f81f-11e6-a761-1f9a5334a1de: fetchObjectById: tried '3' times, exception getting object by id: 4d5807d3-44270f0b-0ad44489-c523322: java.io.EOFException

        at java.io.DataInputStream.readInt(DataInputStream.java:392) [rt.jar:1.8.0_101]

        at java.io.ObjectInputStream$BlockDataInputStream.readInt(ObjectInputStream.java:2848) [rt.jar:1.8.0_101]

        at java.io.ObjectInputStream.readInt(ObjectInputStream.java:974) [rt.jar:1.8.0_101]

        at com.netegrity.llsdk6.imsimpl.managedobject.TaskImpl._readExtendedInfo(TaskImpl.java:1587) [imsapi6.jar:]

        at com.netegrity.llsdk6.imsimpl.BaseObject._deserialize(BaseObject.java:1754) [imsapi6.jar:]

        at com.netegrity.llsdk6.imsimpl.TunnelObject._deserialize(TunnelObject.java:928) [imsapi6.jar:]

        at com.netegrity.llsdk6.imsimpl.managedobject.AdminTaskImpl.readObject(AdminTaskImpl.java:85) [imsapi6.jar:]

        at sun.reflect.GeneratedMethodAccessor59.invoke(Unknown Source) [:1.8.0_101]

Cause

There is corrupt data being stored in the following locations

<jboss home>\standalone\tmp directories on both the Jboss instances. 

<jboss home>\standalone\data directories on both the Jboss instances. 

<jboss home>\standalone\log directories on both the Jboss instances. 

Environment

Jboss Application Server

Resolution

To resolve this we must clear out the corrupt data in the Directories below.

Archive the <jboss home>\standalone\tmp directories on both the Jboss instances. 

Archive the <jboss home>\standalone\data directories on both the Jboss instances. 

Archive the <jboss home>\standalone\log directories on both the Jboss instances. 

*Please make sure to back the data up elsewhere in case it is needed*

Once the folders are cleared out please start your Jboss Application Server up again and the issue should be resolved. 

 

Additional Information

Application Server must be off in order to archive the corrupt data.