Unable to Add Server in CodeMeter WebAdmin when Setting Up Concurrent Licensing

book

Article ID: 5704

calendar_today

Updated On:

Products

CA Agile Requirements Designer

Issue/Introduction

While trying to setup my licensing server and user machines for concurrent licensing with Agile Designer, I am unable to click the 'Apply' button in the WebAdmin when adding the server IP address/name.

 

Steps taken:
(Following directions in this document: https://knowledge.broadcom.com/external/article?articleId=9628)

 

  1. Launch CodeMeter WebAdmin in your current browser and you will see it open to the 'Container' tab. 

  2. Click on the 'Configuration' tab.

  3. In the 'Server Search List' box, click on the '+ add new Server' option. 

  4. In the text box, 'Enter the Server's name or IP-Address'.

  5. Click the 'Apply' button.

 

Expected result: I should be able to click the 'Apply' button and see the server name in the 'Server Search List' box.

Actual result: The 'Apply' button is greyed out, and I am unable to click it.

Cause

This problem could be caused by one or more of the following:

  1. You are not using the standard installation of CodeMeter software (through the ARD prerequisite installer) and instead are using the CodeMeter.ini file.
  2. You are copy/pasting the IP Address or Server Name into the text box, instead of typing it out manually.
  3. The WebAdmin application does not have the needed write permissions for the Registry and the CodeMeter/Server.ini file.

Environment

 

Release : 2.10+

Component : CA Agile Requirements Designer

 

Resolution

The most common resolution to this issue is to try manually typing out the IP Address or Server Name. If you copy/paste it into the text box, the 'Apply' button will not appear.

 

If that does not work, we suggest you try re-installing ARD and make sure that CodeMeter is installed as part of the prerequisites. Admin access is required for this program (CodeMeter) to be installed and used. If you do not have this, you might run into further issues later on.

 

If you are still having issues, please open a support case and provide answers to the information below:

  1. Did you use a standard installation of the CodeMeter software by installing it as part of the required prerequisites in the ARD installation wizard or did you use an adapted installation by using the 'CodeMeter.ini' file?
  2. Please send us the CmDust.log file from the machine experiencing the issue. You can find directions on how to create a CmDust log here: https://www.wibu.com/support/faq/detail/how-do-i-create-a-cmdust-file.html
  3. Is CodeMeter.exe running on the "System" account as a Service?
  4. Do you have administrator/write access on the machine?

Additional Information

If you experience any issues, please open a support case on https://casupport.broadcom.com/user/ or call CA Customer Care at one of these numbers https://www.ca.com/us/services-support/ca-support/contact-support.html?intcmp=footernav

Attachments

1558707704769000005704_sktwi1f5rjvs16qsq.png get_app
1558707702618000005704_sktwi1f5rjvs16qsp.png get_app
1558707700850000005704_sktwi1f5rjvs16qso.png get_app
1558707698880000005704_sktwi1f5rjvs16qsn.png get_app
1558707696508000005704_sktwi1f5rjvs16qsm.png get_app