LDAP error code 49 - DSID-0C09030B
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LDAP error code 49 - DSID-0C09030B

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Article ID: 55146

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Updated On: 09-10-2024

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Lightweight Directory Access Protocol (LDAP) properties in Clarity System Administration (CSA) application is configured, followed by services restart. Even after this, it is not possible to login to the application using the LDAP username and password.

Enabling DEBUG messages for com.niku.security class results in the following message being logged in the app-ca.log:

ERROR 2015-02-19 10:31:28,380 [ApplicationServerThread] niku.security (unknown:security.loginAction)
Authentication failed for::xxxxxxxxxxxxxxx::due to this reason::[LDAP: error code 49 - 80090308: LdapErr: DSID-0C09030B, comment: AcceptSecurityContext error, data 52e, v893]

Cause

This error corresponds to:

80090308: LdapErr: DSID-0C09030B, comment: AcceptSecurityContext error, data 52e, v893
DATA: 52e
HEX: 0x52e
DEC: 1326 - ERROR_LOGON_FAILURE
Logon failure: unknown user name or bad password.
*note:most common reason is invalid password

Resolution

  • The LDAP Search User (Bind User) value entered in the CSA, Security Properties page is not correct or does not have the correct password
  • Confirm that you have entered the fully-qualified distinguished name for the Search User
  • Ensure that the Search User password is correct
  • Both the name and the password are case sensitive.

Additional Information

  • Please check the Clarity properties file and update the password (adminCredential).