The following error messages are appearing in the log - what is the cause and how can it be resolved?
CAVF0002E NO SVA MEMORY AVAILABLE
CAVF0009E INTERNAL ERROR 0C-84-12-251 TERMID=xxxx
This problem usually happens when users are importing / viewing / saving extremely large members in their OLL libraries.
VOLLIE allocates the maximum of 3x20K pools in SVA, regardless of the total free space available. If you are dealing with large members or when using many OLL files or when many users are signed on to VOLLIE, it is possible to reach the maximum SVA memory allocation.
Cause:
This problem usually happens when users are importing / viewing / saving extremely large members in their OLL libraries.
VOLLIE allocates the maximum of 3x20K pools in SVA, regardless of the total free space available. If you are dealing with large members or when using many OLL files or when many users are signed on to VOLLIE, it is possible to reach the maximum SVA memory allocation.
Resolution:
Enter SET DISPLAY SVA on the Vollie console, and the resulting output will show if all the secondary allocations are in use, as in the following example:
*** SVA Memory Allocation ***
Allocation Parameters: 20480, 20K, 3 Size of file table: xxx
Total allocated: 40960 in use: 20560 max. reached: 58920 Secondary allocation, current count: 1 max. reached: 3 Total Largest Block Smallest Block Pool Size In Use Free In Use Free In Use Free 19488 15408 3056 10656 800 16 8 20480 3160 17064 1776 11768 56 496
To increase the Primary allocation to 99K instead of 20K, take the following steps.
In order to conserve storage further, you may wish to refer to section 4.11.2 of the CA-VOLLIE SYSTEMS PROGRAMMERS GUIDE which documents the removing of sign on records after system termination and section 4.13 which documents the USRSGNON command which allows an individual user to remove their own Sign On records.