DSM-Explorer errors: "An invalid argument has encountered" or "Encountered an improper argument"
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DSM-Explorer errors: "An invalid argument has encountered" or "Encountered an improper argument"

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Article ID: 54339

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Updated On:

Products

CA Client Automation

Issue/Introduction

While selecting a computer under 'All Computers' in the DSM Explorer or while

selecting 'All Scalability Servers' objects or selecting Computer Groups the following

error occurs: "An invalid argument has encountered" or "Encountered an improper argument"

 

Environment

Client Automation - All versions

Cause

This error occurs when there is invalid information present in the registry for the

following subkeys: ColumnFilters, ColumnOrders, ColumnWidths and ListSortings

 

Resolution

IMPORTANT: This article contains information about modifying the registry.


Before you modify the registry, make sure to create a backup of the registry

and ensure that you understand how to restore the registry if a problem may

occur. For more information about how to backup, restore, edit the registry,

please review the relevant Microsoft Knowledge Base articles on support.microsoft.com.

Solution:

  • Delete the ColumnFilters, ColumnOrders, ColumnWidths and ListSortings subkeys from the following registry key:
    HKEY_CURRENT_USER\Software\ComputerAssociates\EGC3.0N

  • Reopen the DSM Explorer.

***Note:
The impact of deleting these subkeys is only 'cosmetic'.


Whenever a user clicks on a column heading in the DSM Explorer, the output

in that screen will be sorted for that column. The change in sort order is stored

in the registry.


Also when the width of a column is changed in the DSM Explorer, the change

is stored in the registry.


All these changes are essentially cosmetic and if this is reset to the default.

There are no problems when the user logs in and makes changes to the

column width, order, etc.,