soitoolbox utility fails to connect to SQLServer Instance
search cancel

soitoolbox utility fails to connect to SQLServer Instance

book

Article ID: 5380

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

soitoolbox --findDBInconsistencies -m <sqlserverName\instanceName> -u <dbuser> –p <dbpassword in plaintext>

fails with the following error message:

 

Started 18/01/2017 at 08:54:22
-> Initializing DB connection to [email protected]<sqlserverName\instanceName> (timeouts=20/30)... DONE
-> Checking DB schema version... DONE

-> Looking for orphan candidates... DONE, found 0
-> Looking for orphan CIs... DONE, found 0
-> Looking for Catalyst Inconsistencies... ERROR: ('Exception:', ProgrammingError('42000', '[42000] [Microsoft][ODBC SQL
Server Driver][SQL Server]Error converting data type nvarchar to varbinary. (8114) (SQLExecDirectW)'))

Environment

SOI 3.3 - 4.0 SP2all supported SQL Server versions

Cause

the soitoolbox command line option -m does not support SQL Server Instance

Resolution

create a configuration file for the soitoolbox utility to connect to SQL Server Instance.

 

  • --credentials
    Specifies the location of the file containing the user names and passwords for all systems that run CA SOI components. This command is required when you operate a distributed CA SOI instance.
  • -x
    Creates a configuration file template if the file does not exist.

For example:

soitoolbox --credentials=soitoolbox.cfg

 

edit soitoolbox.cfg and update the SQL Server connection credentials.

For example:

 

2. specfiy credentials for SOI Database

Syntax:
database=<databaseName>:<machineName>;<instance>;<port>;<PlainTextPassword>

 

Additional Information

https://docops.ca.com/ca-service-operations-insight/4-0-cu1-sp2/en/administrating/database-maintenance/ca-soi-toolbox-utility