ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

After upgrading to Top Secret release 12.0, I am getting errors when I activate a CICS TS 1.3 region.

book

Article ID: 53402

calendar_today

Updated On:

Products

Cleanup Datacom DATACOM - AD CIS COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS COMMON PRODUCT SERVICES COMPONENT Common Services Datacom/AD CA ecoMeter Server Component FOC EASYTRIEVE REPORT GENERATOR FOR COMMON SERVICES INFOCAI MAINTENANCE IPC UNICENTER JCLCHECK COMMON COMPONENT Mainframe VM Product Manager CHORUS SOFTWARE MANAGER CA On Demand Portal CA Service Desk Manager - Unified Self Service PAM CLIENT FOR LINUX ON MAINFRAME MAINFRAME CONNECTOR FOR LINUX ON MAINFRAME GRAPHICAL MANAGEMENT INTERFACE WEB ADMINISTRATOR FOR TOP SECRET Xpertware Top Secret Top Secret - LDAP Top Secret - VSE

Issue/Introduction

Description:

These errors are shown when activating a CICS TS 1.3 region under Top Secret release 12.0:

+DFHXS1103I A003CIC4 Default security for userid CICSUSER has been established.
+DFHUS0050 A003CIC4 The default userid CICSUSER cannot be used by this CICS job
+DFHDM0105 A003CIC4 Unsuccessful initialization of DFHUS domain. CICS will terminate.
+DFHME0116 A003CIC4 002

(Module:DFHMEME) CICS symptom string for message DFHDM0105 is

PIDS/565514700 LVLS/530 MS/DFHDM0105 RIDS/DFHDMDS PTFS/UQ66734

PCSS/DFHUS

+DFHDU0303I A003CIC4 Transaction Dump Data set DFHDMPA closed.

+DFHKE1800 A003CIC4 ABNORMAL TERMINATION OF CICS IS COMPLETE.

IEF450I MDCICS MDCICS - ABEND=S000 U1800 REASON=00000000 009

What is wrong?

Solution:

Top Secret release 12.0 does NOT support CICS Transaction Server Release 1.3 anymore (nor does IBM).
The required support module CAKSRD53 is not included anymore in the Top Secret 12.0 library.

The UPGRADE PIB QI93112 states (extract):

Support for Application/Database Releases
-----------------------------------------
CTS Rel 3.2, 3.1, 2.2, 2.3, 3.1 supported at SP00

The same information can also be found in the Support Online portal; sign - on to the portal, then click on the Compatibilities link on the left of the home page; this will take you to the Compatibilities page; in that page, click on the CICS TS Compatibility link under the heading Mainframe Environments; in the resulting CICS TS Release Compatibility page, click on the Security, Control and Audit link, and you will be guided to the Product Information Bulletin LI85233. Here is an extract of that PIB:

--------------------------------------------------------
Release 12.0 of eTrust CA-Top Secret for z/OS and OS/390
--------------------------------------------------------
CTS 2.2  Supported at all servicepack levels (FMID CKOC010).
CTS 2.3  Supported at all servicepack levels (FMID CKOC010).
CTS 3.1  Supported at all servicepack levels (FMID CKOC010).
CTS 3.2  Supported at all servicepack levels (FMID CKOC010).

Environment

Release:
Component: AWAGNT