Javelin error "Publish action failed, action name: <xyz>, HOST actions are not enabled"

book

Article ID: 5330

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When I run a flow in Javelin that includes a post-publish action defined from the TDM portal, I am seeing the error “Publish action failed, action name: <xyz>, action type Post-Publish, action code type HOST, HOST actions are not enabled. Contact your administrator”.

How can I resolve this issue?

Cause

This error occurs because a property is missing in the application.properties file in the TDM Portal configuration.

Environment

TDM 3.8 and later

Resolution

Please edit your application.properties file that is by default under "C:\Program Files\CA\CA Test Data Manager Portal\conf" and enable host actions by adding this line: 

tdmweb.enableHostActions=true

Additional Information

If you face any issues following these steps, please open a support ticket through https://support.ca.com or by calling CA Customer Care using one of the numbers listed on this page: http://www.ca.com/us/services-support/ca-support/contact-support.html.