Notify to mail is failing with XCOMN0988E error XCOMNTFY script setup
search cancel

Notify to mail is failing with XCOMN0988E error XCOMNTFY script setup

book

Article ID: 5315

calendar_today

Updated On:

Products

XCOM Data Transport XCOM Data Transport - Windows XCOM Data Transport - Linux PC XCOM Data Transport - z/OS

Issue/Introduction

Trying to configure to notify userids by mail when a transfer completes but it fails with this error:  

XCOMN0988E Error sending notification, Check SMTP Server name, source or destination address

 

Environment

XCOM r11.6 SP01 for Windows

Cause

 

The failure was due to the userid to be notified <whom to notify> not having the domain as part of the email address. 

 

Resolution

 

These are the parameters that need to be configured to send SMTP notifications: 

 

In xcom.glb: 

• MAIL_TYPE=SMTP 

• SMTP_SERVER=<ipaddrss or hostname of SMTP server> 

• MAIL_USERNAME parameter value will be used as sender to send SMTP notifications. 

 

In xcom.cnf: 

 

For Local Notification: 

• LCLNTFYL=ALL 

• NOTIFYL=MAIL 

• LOCAL_NOTIFY=<whom to notify> 

 

For Remote Notification: 

• RMTNTFYL=ALL 

• NOTIFYR=MAIL 

• NOTIFY_NAME=<whom to notify> 

NOTE : The SMTP server must  be within the internal organization, it will not work sending to an external service provider SMTP server (e.g. Yahoo / Google ) and the default port of 25 for XCOM must be used..  

 

To resolve this, either change the SMTP server to set up aliases for any userid that may be required to receive email notifications, or hardcode the value of the userid's email address in the xcomntfy.bat script, or code the script to add the domain portion. A group id containing multiple email addresses can be set up and used as the email address that is to be notified.

For example, to hardcode the value of the userid's email address in the xcomntfy.bat script, the following change is needed: 

 

Original section of the xcomntfy.bat:

:CHECK_MAIL_TYPE

if NOT /%mailtype%/ == /SMTP/ GOTO EXEC_MAPI

%xcomqm% -D%q_entryname% | %xcomsmtp% %q_entryname% %who% 

GOTO END

 

Change this to:

:CHECK_MAIL_TYPE

if NOT /%mailtype%/ == /SMTP/ GOTO EXEC_MAPI

%xcomqm% -D%q_entryname% | %xcomsmtp% %q_entryname% [email protected]

GOTO END

 

NOTE:

If the value is hardcoded in the script, then XCOM will always send emails to this mail ID irrespective of what is specified in the transfer configuration parameters. If it is required to be able to send mails to different mail ids, then the script will need to be extended and modified to set the %WHO% value to the corresponding mail id based on the value from the transfer configuration parameters.  

To test the connection for a Local Notify

Set up a loopback transfer:

Example:

  1. create an xcom.cnf file c:\notify.cnf Specifies the local user notification level.
    REMOTE_SYSTEM=127.0.0.1
    PORT=8044
    LOCAL_FILE=c:\local_test.fil
    REMOTE_FILE=c:\remote_test.fil
    FILE_OPTION=REPLACE
    USERID=xxxxxxxx
    PASSWORD=xxxxxxxx
    LCLNTFYL=ALL - Specifies the local user notification level
    LOCAL_NOTIFY=xcomuser - The LOCAL_NOTIFY parameter specifies the user on the local system to notify when a transfer completes.
    NOTIFYL=ALL Displays a pop-up message on the local system console where the user, xcomuser, is logged in.

  2. To use this option, your local %XCOM_HOME%\xcomntfy.bat file must specify set use_pop=YES.
  3. To submit the transfer, type on the command line: %XCOM_HOME%\xcomtcp -c1 -f c:\notify.cnf
  4. This transfer will initiate a loopback transfer and NOTIFY the LOCAL logged on user, xcomuser, with a pop-up. 

 

 

  

 

Additional Information

The following commands were used to help debug the problem

telnet <smtp server> 25

helo hi

mail from: <from_address>

rcpt to: <userid>

the errors received from telnet showed that the domain portion of the email address was required to be successful.