Getting "Primer authentication failed" message when trying to deploy an Agent to a Windows workstation.
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Getting "Primer authentication failed" message when trying to deploy an Agent to a Windows workstation.

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Article ID: 52691

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

The ITCM/DSM deployment system uses reverse lookup techniques in order to get the DSM Server name from its IP address. If this resolution does not succeed the deployment cannot be completed and some errors arise.

Environment

Client Automation - All Versions

Cause

The most likely cause for this error message to be displayed is the impossibility of the workstation to find the Domain Server name based on its IP address.
You can verify it by running the following commands:

From the DSM Server computer:

camping -a <failing_workstation_name>  

and get an output like:

camping: Trying <failing_workstation_IP_address> ...         Local reverse lookup gave: <failing_workstation_name>       CAM on "<failing_workstation_name>" is alive.       The remote computer identifies itself as:-               "<failing_workstation_FQDN>" at address <failing_workstatiojn_IP_address>and knows this computer as:-         "unknown" at address <DSM_Server_IP_address> Note: returned remote hostname differs from local reverse lookup!       This computer calls itself "<DSM_Server_FQDN>" at IP address <DSM_Server_IP_address>  

From the failing workstation:

   nslookup <DSM_Server_IP_Address>  

and get an output like:

   Server: <DNS_Server_Name>   Address: <DNS_Server_IP_Address>  
*** <DNS_Server_Name> can't find <DSM_Server_IP_Address>: Non-existent domain  

Resolution

In order to solve the reverse lookup problem you can proceed with one of the next suggestions:

  1. Contact your network administrator and ask him/her to review the DNS server the workstation is using in order to verify:

    • If it is able to resolve the DSM server name into its IP address.

    • If it is able to resolve the DSM Server IP address into its name.

  2. On the workstation being deployed, use notepad to edit the file %WINDIR%\System32\Drivers\etc\hosts and add the following line at the end:
    <IP_address_of_DSM_Server> <DSM_Server_HostName> <FQDN_DSM_Server_Hostname>

NOTE: If the problem is not solved with this procedure, please open a case in support.broadcom.com