Clarity PPM - MSP - "RunTime Error! ..\Schedule Connect\bin\SchedLink.exe".

book

Article ID: 52512

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When launching a project from CA Clarity PPM UI to MSP, the following error message is shown:

Environment

Clarity PPM 15.5

Resolution

IMPORTANT: This article contains information about modifying the registry.
Before you modify the registry, make sure to create a back up of the registry and ensure that you understand how to restore the registry if a problem may occur.
For more information about how to back up, restore, and edit the registry, please review the relevant Microsoft Knowledge Base articles on support.microsoft.com.

    1. User has to have read/write rights to:

      HKEY_LOCAL_MACHINE\Software\Niku
      HKEY_CURRENT_USER\Software\Niku.

    2. Flush java cache and Internet Explorer temporal files.

    3. The server name needs to be added in the "Scheduler URL Entry" on the NSA.

    4. From the command prompt, type "java -version". Verify that Java version is the right one for your MSP and Clarity version.

    5. From MSP Tool -> Options -> Calculation tab: Verify the calculation mode. If it's set to "Manual", try to select the calculation mode "Automatic" and click "Set as Default".



      If still problem is not solved:

    6. Uninstall/Reinstall following the right steps: ? Uninstall all your java versions and install back the java.

      • From the Control Panel uninstall:

        • Clarity Interface for Microsoft Project.

        • Clarity Schedule Connect.

      • Launch MSP.

      • Close the empty project that MSP automatically created.

      • pre-MSP2010: Go to Tools-> Macros -> Visual Basic Editor.

        • Expand the ProjectGlobalSection.

        • Expand the Modules folder.

        • Right click on a Module with Niku_ or CA_ as part of its name.

      • MSP2010: Go to File -> Info -> Organizer

        • Go to Modules Tab.

        • Select the modules in Global.mpt with Niku_ or CA_ as part of its name.

      • Select Remove.

      • Choose "No" to the export question.

      • Do this for all Niku Modules.

      • Close the Macro editor.

      • Close MSP - if a Debug error comes up, choose debug, then delete all text and close out, choosing "Yes" or "OK" at the prompts.

      • Delete the following folders:

        C:\Program Files\Clarity
        C:\Program Files\Clarity Setups

      • Delete the following two keys in the Registry:

        HKEY_CURRENT_USER\Software\Niku
        HKEY_LOCAL_MACHINE\Software\Niku

        ** Note: Export and enter a File Name to store the back up of the registry keys.

      • Exit the Registry Editor.

      • Reboot the system.

      • Re-download the install files for the MSP Interface from your Clarity application server.

      • Run the install.

      • Before completing the MSP-Clarity integration installation, verify the following:

        1. Launch MSP

        2. Pre-MSP2010: Choose Tools -> Macros -> Security.

          MSP2010: Choose File -> Options -> Trust Center -> "Trust Center Settings?"

        3. Set the level to Medium, if it is not already (for pre-MSP2010). For MSP2010: Set Macro Settings "Enable all macros (not recommended)"

        4. OK to save setting change.

        5. Close MSP

        6. Pre-MSP2010: Double click the MSPAdd2K.mpp (C:\Program Files\Clarity\MSPInterface\data). Choose Enable Macros when prompted.
          MSP2010: Open MSP and you should be prompted with a message asking whether you want to install the CA Clarity Integration as Toolbar (default) or Menu. Confirm your choice.

        7. Install should be complete.

If still problem is not solved:

  1. Check the MSP integration went ok.

    • Locate file MSPAdd2K.mpp (on my machine it is under: C:\Program Files\Clarity\MSPInterface\data\) and open it with MSP.

    • Enable Macros.

    • Go to the command prompt under C:\Program Files\Clarity\Schedule Connect\bin directory and type in this command: schedlink /s

    • Now try launching a plan from Clarity.

  2. Check the "List separator" is a "semicolon" from Control Panel -> Regional and Language Option -> click on "customize..."

Attachments