Users receive 'Delayed Server Response' message when attempting to open certain CA Service Desk Manager (CA SDM) Knowledge Documents
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Users receive 'Delayed Server Response' message when attempting to open certain CA Service Desk Manager (CA SDM) Knowledge Documents

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Article ID: 5250

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Users receive 'Delayed Server Response' message when attempting to open certain Service Desk Manager (SDM) Knowledge Documents.

The following error appears within the STDLOG: 

No response to ATTR_INIT trigger KDGetgroupList (2 time) after 60 seconds; waiting another 120 seconds 

Environment

Service Desk Manager

All Supported Operating Systems

Cause

This type of error is related to data issues within the KT SKELETONS MDB tables. 


The READ_PGROUP and WRITE_PGROUP fields contain the groups of CA SDM groups that are eligible to read/edit the Knowledge Document.


If the groups identified by the READ_PRGROUP and WRITE_PGROUP values are not found within the control P_GROUPS MDB table, then the Knowledge Document cannot be accessed since the security validation cannot be performed.


The proposed solution will identify and address KT Documents where the group security permissions are out of sync.

  

Resolution

Run the following SQL queries against the MDB 

select id from SKELETONS where READ_PGROUP !=0 AND READ_PGROUP NOT IN (select id from P_GROUPS) 

select id from SKELETONS where WRITE_PGROUP !=0 AND WRITE_PGROUP NOT IN (select id from P_GROUPS) 

select id from O_INDEXES where READ_PGROUP !=0 AND READ_PGROUP NOT IN (select id from P_GROUPS) 

select id from O_INDEXES where WRITE_PGROUP !=0 AND WRITE_PGROUP NOT IN (select id from P_GROUPS) 

If any rows are returned from the above queries, perform the following 

1. Take a backup of the SKELETONS and O_INDEXES MDB tables by running the following commands via a command prompt on the SDM server 

pdm_extract SKELETONS > C:\skeletons.txt 
pdm_extract O_INDEXES > C:\O_indexes.txt 

2. Stop the SDM service 

3. Run the following SQL queries against the MDB database 

UPDATE SKELETONS set READ_PGROUP = 0 where READ_PGROUP !=0 AND READ_PGROUP NOT IN (select id from P_GROUPS) 

UPDATE O_INDEXES set READ_PGROUP = 0 where READ_PGROUP !=0 AND READ_PGROUP NOT IN (select id from P_GROUPS) 

UPDATE SKELETONS set WRITE_PGROUP = 0 where WRITE_PGROUP !=0 AND WRITE_PGROUP NOT IN (select id from P_GROUPS) 

UPDATE O_INDEXES set WRITE_PGROUP = 0 where WRITE_PGROUP !=0 AND WRITE_PGROUP NOT IN (select id from P_GROUPS)


4.  Restart the SDM Service